Identified - Genius + and Genius CE sites are providing a 500 error

Incident Report for Genius

Resolved

Genius has resolved the service disruption issue. Thank you for your patience and understanding.
Posted Jun 09, 2026 - 10:28 EDT

Identified

We're currently experiencing a service disruption. Our team is aware and actively working to restore access as quickly as possible. We apologize for the disruption and will share updates as they become available. Thank you for your patience.
Posted Jun 09, 2026 - 10:07 EDT
This incident affected: Enterprise+.